Topic: XCode tools required - what size?

It just galls me to have to install XCode at 26GB in order to have the toolset needed for Simply Fortran. SF isn't the only app that needs them. I think Python needs them installed too.

We chatted about installing the tools many posts back but I haven't found that post to review it. Maybe it was just an email.

Can I delete XCode and install the required tools with HomeBrew just the terminal app and save gigabytes of space?

My concern is all the pathname shenanigans I deal with using the terminal app. For example, I saw a YouTube that showed the command needed to install the tools via the Terminal app - I'll have to re-find it. If I install it that way, will Simply Fortran be able to find/use them as needed? No "path" issues?

If XCode weighs in at 26GB, how much would I save by just installing the toolset Simply Fortran (and other apps) need?

Re: XCode tools required - what size?

Simply Fortran absolutely does not require XCode to work.  It actually only requires the Command Line Developer Tools in order to access Apple's linker, the development libraries, and some source control tools.  You shouldn't have to install XCode (I certainly don't have it installed on my modern Intel Mac or Apple Silicon Mac) to run Simply Fortran.  You can simply enter the following command in any terminal:

xcode-select --install

One issue, however, is that Apple's utility for installing the Command Line Developer Tools is notoriously flaky, especially if you've recently upgraded your operating system, and sometimes the simplest fix is just to install XCode.

If you install Homebrew after removing XCode, it should also trigger the Command Line Developer Tools installation, which is all Simply Fortran needs.

I assume, by "path issues," you're referring to Apple's change that moves the system development libraries to a non-standard (for Unix) location.  We attempt to account for that in our Development Terminal by setting an environment variable, SDKROOT, to the appropriate path.  But if you open an arbitrary terminal and attempt to use Simply Fortran's compiler, you will have to set the path to Simply Fortran's package directory and the SDKROOT environment variable appropriately.  The system library location is a decision by Apple, not us. 

I'm not sure how much space the Command Line Developer Tools and the requisite software development kits take up.  It isn't a trivial amount of space, though.

Jeff Armstrong
Approximatrix, LLC

Re: XCode tools required - what size?

Thank you for your prompt reply. Yes, it's the "Command Line Developer Tools" I was referring to.
I'll delete XCode, check the size of the main drive to see if I get back my 26GBs, then from the terminal command line I'll type xcode-select --install and check the drive size again.

I have homebrew installed (for envpy stuff), but the terminal world's vocabulary and commands are foreign to me. I would not run Simply Fortran from the terminal app.

If I run into trouble, I'll just reinstall Xcode. I moved from a 128GB mini to a 512GB so that  26GB Xcode footprint isn't that big a deal. It's just the principle of the thing.

Re: XCode tools required - what size?

The vast amount of space used by Apple's development tools is unfortunate, and I'm not disagreeing with you at all concerning our requiring them.  While many of Apple's tools are "open-source," they tend to be so in theory only.  We've tried to package a linker in the past with Simply Fortran for macOS, but it was needlessly complicated to compile.  Furthermore, modern macOS releases don't include a linkable system library; one needs the full suite of their development tools for access to the linkable stubs for the system library.

Jeff Armstrong
Approximatrix, LLC

Re: XCode tools required - what size?

Well, that was interesting. I copied stats to a note file - the available space on my disk. Then I deleted XCode - it showed hundreds of files being deleted. But after all that - checking GetInfo, the available space on the HD remained the same.

Then I ran your script on the terminal app and it said the development tools were already installed - probably because of a previous Python install or some such. I am NOT a fan of hidden files and "keeping things simple for the user". Too many activities going on behind the scenes. I was able to download the latest AppleSilicon SF and on the older machine, the latest INTEL version.

But I ran into trouble there just trying to open the .dmg. So ... the usual tech support mantra - I rebooted both machines and lo-n-behold things started working again. A file designated Read/Write that would let me open it (fortran tutorial .pdf) would now open, etc.

It's becoming more like witchcraft with every Apple update.  Thankfully, Simply Fortran is pretty darn'ed solid.