Topic: Editor stuck in a loop during 'Replace all'

With a source file open in an editor tab, I have,
pressed                           Ctrl-F,
then entered in Find:        ParPAN
then entered in Replace:  idParPAN
then clicked                     Replace All

This caused the editor to become stuck in a loop on line 41 (out of 249 in the file).
I know it was line 41 because the status line showed Line 41 Column nnnnn, where nnnn was rapidly heading into tens of thousands.

Killing it and re-trying gives the same result.

Killing it and checking the source file reveals no characters in line 41 beyond about char position 50.

Editing the line by inserting a C/R at the end then DELeting whatever was there before, and re-testing, gives the same result.

Re: Editor stuck in a loop during 'Replace all'


I was under the impression that such bugs have been eliminated, but apparently I am wrong.  My guess is that the editor is infinitely replacing a single instance of the ParPAN over and over again because the replacement term also includes the text "ParPAN."  There is logic to avoid this usually, but apparently the logic is failing.  I'll take a look and see to it that it is fixed.

Jeff Armstrong
Approximatrix, LLC