Topic: Lost permissions to build AppGraphics program

I am feeling really dumb but my AppGraphics plotting program seems to have lost its permissions to write files. It has been a while since I worked on this code and I noted that the project file seemed to have lost information (not sure how) like the source code file was no longer associated with the project.

I think I replicated the project settings but now when I try to build the code, I get a windows pop up window that says
"An error occurred while writing the Makefile. Please check permissions and Makefile settings"

I did check the settings but I can't see how they might have changed.

Any suggestions?

I am running this on Win7 Pro and I have SF version 2.23 build 1876. Also, I am able to build other project is seems, but this one seems to be trouble. 


Re: Lost permissions to build AppGraphics program


In what directory is your project saved (full path if possible)?  It could be a path issue.  Also, have you tried copying your source and project files to a new directory (don't copy the directory they're in, though) and trying to compile them?

Finally, you might consider installing the latest version (2.30) as it does address plenty of bugs that have been discovered since 2.23.  However, upgrading would be at your discretion.

Jeff Armstrong
Approximatrix, LLC

Re: Lost permissions to build AppGraphics program

Thanks Jeff,

This is my second attempt at a reply as the first timed out while I was at work yesterday, ugh!

Ok, so what I did was check my file locations for my working directory which is e:\Fortran_Projects\Rplot. All the file locations look correct from what I can tell and I still get that permissions message.

Then I copied the program and the project file to a new directory and the project immediately built the executable without any issues. So I am able to work on the code this way but I still want to be able to work from the original location since I have hooks to that folder to archive code and such. 

As I am writing this, I realize I have not tried the old directory again so I do. Today I am not getting the build failure, so it is working again. I have no idea why, I did nothing but copy files out of the directory. The changes I made in the temp file structure, I moved back to the old directory and it compiles fine.

Shaking head here as to what happened. If you have any ideas, feel free to share but as things seem to be back to normal I will exit stage left with chagrined look on face.

Thanks for your help!