Topic: wmake issue


I am trying to run an example file as well as my own code on SF 3.2 B2981 on  my VM (Linux Mint 19.1 cinnamon).  I ran my code repeatedly in the morning without any problems. But, suddenly after a few  hours I get errors like this! (See attached)

I have reinstalled glibc and make to be really sure, unfortunately the error still persists.

Anyone having the same issue?

This is displayed in the *build status* window

sh: 1: /tmp/.mount_NQKsTU/usr/bin/wmake: not found

* Failed *

Re: wmake issue

Solved it!

SF just changed the path of wmake. I just pathed it to /usr/bin/wmake.

Re: wmake issue

Actually, the answer may be a bit more complicated than that.  Jeff will likely answer more completely (and correctly!), but I believe for your version of SF, a new instance of SF for a user is created in a tmp directory such as was reported in the error message.  I am wondering if that tmp directory was purged (or partially purged) by a system cron job, which left the SF instance broken.

Re: wmake issue


I'm not sure how the path for make was changed to the explicit directory location, but it may be a remnant of how the paths are updated.  You should be able to change the path to simply "wmake" without any directories since it should always be on the path.  I'll look into how and why it explicitly updated the path to its per-run location.

Jeff Armstrong
Approximatrix, LLC